2008 Suzuki Grand Vitara DDiS Turbo Diesel

6 years 6 months ago #1 by Andy
This is my new pride and joy, Suzuki Grand Vitara DDiS JT MY09 1.9L Turbo Diesel.

A few specs:

* Renault sourced engine
* Bosch high pressure common rail injection system
* Garret intercooled turbo
* All wheel drive
* REAL 4 x 4 system, low range, diff locks etc.
* ESP and 6 airbags etc.
* One female owner since new (never been offroad)
* Full factory optioned at purchase, including tow bar, sidesteps, nudgebar and tint.
* Bridgestone Dueler A/T, recently fitted.
* Aftermarket "M series" add-on alarm (fitted by Suzuki)
* Factory audio, crappy head-unit and about 10w speakers.....atleast it has MP3 capabilities, no iPod. Upgrades will follow.

This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.


This image is hidden for guests.
Please log in or register to see it.

6 years 6 months ago #2 by Tezzating
Yay ! I understand you already cleared out the shed of old Honda's and Commodore's as well :P

Now you need to fit a 20% LPG injection system ;)

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 6 months ago - 6 years 6 months ago #3 by Andy
No eBay APP ID défined in Kunena configurationYes, they're either gone or going......geeze, cant a guy collect some stuff? :laugh:

Been looking at the "diesel tuning chip / modules" on eBay, from the looks of it they do what they say? i'd like another 50nm thanks:





Thoughts?


Picking up a set of Lightforce 240 Blitz driving lights for it today, paid for by the dealership :P
6 years 6 months ago #4 by Tezzating
Aparantly the eBay plugin is broke again..

Anyway, that thing looks like a resistor box with dip switches, but I might be wrong ? Have you checked Superchips and those sorta guys ? You know i like a bargain but with ECU tuning I think you really do get what you've paid for.

Replacing the muffler and opening up the intake will prolly give you a pile more horse power.. or do the LPG injection ;) www.mrsharkey.com/lp...
I forget the golden ratio, but up to X percent of lpg injection nets horsepower and fuel economy gains, its well proven. I worked with a dude who had a 20% kit in his Delica Spacecab diesel for the economy gains.

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 6 months ago #5 by zion187reigneth
gas injection for the win, savings will follow
6 years 6 months ago #6 by amcinstaller
one of my friends uncles drives big rigs here and he was using propane injection for a boost to pull the truck up the big hills without downshifting :laugh:
6 years 6 months ago #7 by Tezzating
LPG is like NOS for Diesel :P

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 6 months ago #8 by amcinstaller

Tezzating wrote: LPG is like NOS for Diesel :P


well......yea.... i knew that you know ;)
6 years 6 months ago #9 by Tezzating
Just making sure CCSS is 100% clear on the matter :P

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 5 months ago #10 by Andy
Crystal, but probably not something i "need" just yet, as well as that power chip/module thing.

Suzuki are replacing the sump gasket (small oil leak) and making the necessary repairs to get rid of the diesel injection light that keeps popping up. All under warranty. Could mean a particulate filter "upgrade" (their words) and/or ECM replacement and/or keys being re-coded, apparently that light doubles as the immobilizer so could be as simple as a key problem.

Im off to Coffs Harbour (400km each way) tomorrow for a small getaway, we will see how she fairs ;)
6 years 5 months ago #11 by Tezzating
And an LPG kit right ? :P You can make it out of BBQ parts..

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 5 months ago #12 by Andy
No LPG kit, ive got plenty of time for mods :laugh:

Dont know whats happening with the audio just yet, will approach Rockford Fosgate firstly though.....all that black gear will suit my car :P
6 years 5 months ago #13 by amcinstaller
hopefully aussie rockafellar is better than american rockafellar, i havent been too impressed with it for a few years now :unsure: but on a positive note, yes, you really do *need* LPG injection. everyone does. i do. and my car runs on gas (petrol?)
6 years 5 months ago - 6 years 5 months ago #14 by Andy
Yeah, had a good read in that link.....thanks Tezzating :P

Its probably something i'd be interested in later on, i mean i cant see anywhere to mount the LPG tank under the car, so inside it would have to be.....i dont like that idea much.

Well she did the 850km all fine, hasnt used much oil or water and never gave a problem. Ive picked up a cheap scantool off ebay, $17 delivered. To my amazement it actually works, haha. Gave me the same error code 3 times, P0638 which according to my scantool software and engine-codes.com:

"Throttle actuator control range / performance"

"The Powertrain Control Module (PCM) compares the actual Throttle Possition (TP) with the target TP when the engine is running. If the difference is more than the specification, the PCM determines that there is a throttle actuator control circuit range/performance problem."

Which would explain why the light dosnt come on until its warm and i rev her over 3k, soon as the tacho gauge drops below 3, the light pops up....almost like clockwork. If you drive it under 2.5k (under 25% throttle) the light barely ever comes on.

Apparently a simple remedy could be a throttle body clean, other faults are:

- Drive-by-wire control system malfunction
- Throttle actuator malfunction
- Throttle valve malfunction
- PCM malfunction

So obviously im going to try cleaning the TB first, i'll get some product from work tomorrow and give it a whirl. Otherwise its up to the dealer :laugh:
6 years 5 months ago - 6 years 5 months ago #15 by Tezzating
I've found it easiest to open the intake and have a look at the throttle then gently wipe out the heavier of the packed on shit before hitting it with spray.. then you have easily burnt off liquid rather than big chunks of shit to contend with :P

Shame you dont have a real-time scantool.. I borrowed one and it was nice, real time feedback on the throttle position, injector pulse, etc. That'd tell you real quick if its a sensor issue or something else. Interestingly enough, the Jeep's factory calibration shows idle throttle position as 25% on the TPS

engine-codes.com/p06...

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 5 months ago - 6 years 5 months ago #16 by Andy
Bugger of a job but cleaned the TB, sadly it wasnt very dirty at all....only got a very small amount of crap.....butterfly was clean. Unsurprisingly the light still comes on, but i will try clearing it now and seeing what live data i can access, i know it shows *some*.

Nope, dosent give me throttle position etc, no fuel stats except pressure actually, which is approx 3,500 PSI @ idle. The code re-appears as soon as i scan again, even at idle with the warning light off, it also repeats the code so it shows up twice in the list. First i scanned it was there 3 times. Oh well, i leave it for the dealer i think :laugh:
6 years 4 months ago #17 by Andy
Bit of an update for those who dont know :P

Issues have all been sorted and im a happy 4x4 driver :laugh:

The problem relating to the warning light was apparently the battery. They said the scantool was showing only 8v to the ECM, so they swapped out the battery and the light stayed off! I still dont understand what was wrong with it......it held charge, started the engine fine, ran accessories fine etc etc. Multimeter showed 12.4v on rest, 11.2 on crank and 14.1 when running. Who knows, all i know is the problem is definitely not there anymore, and ive got a new battery :huh:

Been very interested in Pioneer's new AV products, especially this new "advanced app mode" for iPod/iPhone, where you can display apps on the screen of the stereo, even control them using the touch interface......pretty cool i say. Apps like Tom Tom / Navigon and the OBDII-based ones would be cool.
Unfortunately we only get the AVH-P4450BT ( 4400BH i think over there?), which sadly does not have advanced app mode. Just wondering if anyone else has played with this feature on the new "AppRadio" units, or even the model im interesting in possibly importing, the AVH-P8400BH ?
6 years 4 months ago #18 by Tezzating
Nope, never did like Pioneer equipment very much :P If you want one of those units, I could probably send you one.

The lazy mans signature (TM)
Its Decibelcar.com Baby
6 years 4 months ago #19 by amcinstaller
hmmm, that new bit does sound pretty fuckoff cool. unfortunately like i posted in that other thread, im not a fan of them as of late. ive actually been inching back towards a kenwood radio, if i could find one with the features im after without spending an arm and a leg.

so, now that the whole CEL deal is fixed up, wheres your handy LPG injection kit?
6 years 4 months ago #20 by Andy
Im going to have a chat with Joe Barilla, our Pioneer rep next time i see him. The Australian website dosent list it *yet*. We dont have the "Appradio" models here yet either.

I like Kenwood units, always have. Ive noticed over the last year or two their GUI is lacking speed and response. Sometimes ive waited 5 seconds for the unit to actually respond, this has been the case all through their AV range, from the DDX-4038 and even the new 4031, their DNX-7380BTNAV is crap IMO.....we've had 3 come back in the past month, screen shutting off and/or going purple/blue. Everytime its been because of the detachable face, its becomes loose and creates a poor connection. We do not stock another double DIN head-unit that uses a detachable face.
I still have my Alpine 9815 in the Commodore, some days i go close to ordering the facia kit :laugh:

:laugh: LPG Injection kit, still a long way off i reckon......had the car for alomst 3 months and the only thing ive done its fitted 8" driving lights, longest time EVER without a stereo upgrade :ohmy:
Time to create page: 1.489 seconds